Ошибка при обновлении linux-headers

3
143

Хочу немного пожаловаться на Убунту. Система в целом хороша, как магазин игрушек Киев, но… Уже довольно давно, пару месяцев назад, при обновлении пакетов система выдала ошибку. Причем ошибка была связана с обновлением ядра, а именно linux-headers-2.6.32-23-generic. Теперь, при каждом текущем обновлении пакетов или установке новых система выдает следующее:

При обработке следующих пакетов произошли ошибки:

linux-headers-2.6.32-23-generic

Настраивается пакет linux-headers-2.6.32-23-generic (2.6.32-23.37) …

dpkg (подпроцесс): не удалось запустить установлен сценарий post-installation: Ошибка формата выполняемого файла

dpkg: не удалось обработать параметр linux-headers-2.6.32-23-generic (-configure):

подпроцесс установлен сценарий post-installation возвратил код ошибки 2

При этом все остальные пакеты прекрасно устанавливаются и обновляются. Может кто подскажет, как отключить обновление linux-headers-2.6.32-23-generic? Тем более, что система сейчас работает на более свежем ядре.

3 КОММЕНТАРИИ

  1. Было у меня такое, еще на 9.10, но так и не избавился, а потом перешел на 10.04, тут пока все нормально

  2. Попробуйте удалить это ядро из менеджера пакетов.
    1. Для начала выясним текущую версию вашего ядра, для этого наберите в терминале:
    uname -r
    Вы увидите что-нибудь типа этого:
    2.6.24-19-generic

    2. Откройте Менеджер пакетов Synaptic из меню Система -> Администрирование, нажмите кнопку «Найти» и в поле поиска наберите:
    linux-image-2
    3. удаляйте ненужное.

  3. Проблема решилась ампутацией ядра, а потом и исходников 2.6.32-23-generic. Система работает на более свежем ядре и ампутация никак не отразилась на жизнедеятельности системы.

ОСТАВЬТЕ ОТВЕТ

Please enter your comment!
Please enter your name here